Did you know? UBerserker loves the Dispersion Pistol.

Coop help w/ LEGACY by Ezkeel (in OldSkool 2.9) - some teleporters don't work

For discussion of anything relating to multiplayer gameplay in the Unreal series, including co-op.

Moderators: ividyon, Semfry, zYnthetic

NaPaliShore
Skaarj Warrior Skaarj Warrior
Posts: 78
Joined: 25 Nov 2011, 02:05

Subject: Coop help w/ LEGACY by Ezkeel (in OldSkool 2.9) - some teleporters don't work

Post Posted: 08 May 2012, 06:50

Hi folks - hope someone can help me with a coop question!

I'm playing through Ezkeel's very creative LEGACY custom SP map pack with a buddy in coop mode in UT using OldSkool 2.9. We noticed right away that almost none of the cut-scenes are loading in coop mode, which seems to be not that unusual for map packs that were not specifically designed with coop play in mind.

But in some cases we also found that the end-of level teleporter that is supposed to load the next level is not functioning. (Maybe this is happening in those cases where the teleporter is designed to load the cut-scene that leads into the next level, and that's why it is "stalling" at those points?) Mostly I can get around that issue by using the "switchcooplevel" console command to manually load the next level at that point.

However there are certain circumstances where the manual level load trick, using "switchcooplevel" won't solve our problems.

First is the situation where the teleporters that are designed to transport you to other locations *within* the same level/map are not working - notably his happens in legacy-10.unr (The Kalladrad Halls), where the red teleporter at the very beginning of the level is not working, and in fact none of the other teleporters that take you to the various cool "challenges" or puzzles within that level are working, in coop play. Those internal teleporters for the Kalladrad Halls work fine in regular single player mode in Oldskool, just not in coop. And similar "internal" teleporters do work on some of the other maps in the pack - like Legacy-4.unr (The Tower of Elijah), which also has several "puzzles" or challenges that you access via a teleporter. As the "host" of our coop game, I am able to ghost around to the challenges on that map, but my buddy has problems when he tries to ghost (he gets sort of stuck in ghost mode, and when he tries the "walk" command it doesn't make his player stand upright again). So he had to let me finish the Kalladrad Halls by myself, and then rejoin at the next map.

The second situation, and the one that is bugging me the most, is that the teleporter from the end of The Tower of Elijah (Legacy-4.unr), which is supposed to take you back to the "second half" of the Triaxia level (where you revisit that map a second time, only this time you start in a new location at the bottom of the map and pick up a Skorcher and then fight it out with the Warlord in a fun z-axis battle) is not working for us. And in that case if I use the "switchcooplevel" command to try and load the Triaxia map again (Legacy-4.unr), it places us within the map at the original default starting location, rather than the new location that gives you access to the second half of the level. The URL for that teleporter at the end of Tower of Elijah (or rather, from the cut-scene level, Legacy-4cut.unr) seems to be "Legacy-6#legacy6b?peer", and I really don't understand exactly how teleporters work, but I am assuming that the tag "#legacy6b" is some kind of shorthand indicator for the second spawning location in the legacy-6.unr map (Triaxia) - which is where we would like to be starting out when we enter that map for the second time. But I don't know how to get to that second/new location, apart from ghosting over to that little skaarj teleporter room - but in that case my buddy can't follow me because ghosting doesn't work for him in coop mode.

Sorry for this long preamble, but we have FINALLY arrived at my question for all of you:

Can any one suggest a way to either manually load the legacy-6.unr map so that our players will start out the map at that "#legacy6b" location within the map? Or if we made a duplicate copy of that map to mess around with, would there be a way to modify the map itself (in the Unreal Editor) so that it would default to having the player start at that new location? (I guess it would mean editing the PlayerStart(s) for that map? - which I'm not entirely sure how to do.) Or would there be a console command that we could use to instantly transport ourselves to that new location within the map, after loading the original version of the map? Or is there some other work-around that anyone can suggest, in order to get both of us over to that second starting position in the map, while playing in coop mode - either starting the map with us in the right place, or allowing us to relocate to the correct place (maybe fixing the "ghost" function for the second player?)?

Enormous thanks are due to anyone who can help! Sorry for the long rambling post - if I knew more about the terminology and "inner workings" of the game then I could phrase the question much more succinctly and elegantly, but then again if I knew that much then I probably would know the solution to my question already! ;-)

User avatar Core
Skaarj Assassin Skaarj Assassin
Posts: 106
Joined: 15 Mar 2010, 17:16
Location: ../System/
Contact:

Subject: Re: Coop help w/ LEGACY by Ezkeel (in OldSkool 2.9) - some teleporters don't work

Post Posted: 11 May 2012, 22:55

Legacy was indeed not designed with co-op support in mind. There are many things that make coop play in Legacy almost impossible. I've written a couple of fixes for it in ecoop two or three years ago to get some basic coop support for it, you could give it a shot on one of Loathsomes ecoop servers.

If it's just for a strictly private server together with your friends, then yes, you could edit the map and add some teleporters in there, and share the map with your friends. Check the mapping section of http://wiki.beyondunreal.com/ to get the basics of the unreal editor, and http://wiki.beyondunreal.com/Legacy:Teleporter to know how to use a teleporter. If it's a listen server you're hosting, you could spawn the teleporters directly through the summon command and edit their tags/urls through one of the editactor concole commands (eg. editactor class=teleporter).

NaPaliShore
Skaarj Warrior Skaarj Warrior
Posts: 78
Joined: 25 Nov 2011, 02:05

Subject: Re: Coop help w/ LEGACY by Ezkeel (in OldSkool 2.9) - some teleporters don't work

Post Posted: 12 May 2012, 06:46

Core,

Thanks so much for your help! I am indeed hosting a listen server, so I tried your last suggestion and it worked - after loading the level ("open legacy-6"), I then typed "summon visibleteleporter" in the console, followed by "editactor class=teleporter".

Navigating to the "URL" field at the bottom of the Teleporter properties list (which was empty by default), I entered in the new value "legacy6b" and presto! - we now had a quick way to jump to the 2nd starting point in the level.

So that solves my immediate problem. When I have a little time, I might try playing around a little with the unreal editor, to see if I can add some teleporters at key locations in some of the maps, that might re-enable some of the "jumps" that were not working in coop mode.

Thanks again - the UnrealSP community is truly a wondrous thing!

NaPaliShore
Skaarj Warrior Skaarj Warrior
Posts: 78
Joined: 25 Nov 2011, 02:05

Subject: Re: Coop help w/ LEGACY by Ezkeel (in OldSkool 2.9) - some teleporters don't work

Post Posted: 29 May 2012, 04:46

Since my last post, above, I've found a couple of Teleportation mods that have turned out to be helpful in Coop play, when playing on my private listen server with my buddy. (They would probably be considered cheating on a public server, but I guess people wouldn't be able to summon them anyway as clients on such a server...)

The first is Shivaxi's Teleporter (http://shivaxi.com/unreal/downloads/shivaxisteleporter.zip).

Here's the ReadMe file for that:

====================
Shivaxi's Teleporter
====================
Summon - ShivaxisTeleporter.ShivaxisTeleporter

Description - This is an item that goes in your inventory, and when used it will teleport you to the nearest playerpawn.
Useful for giant maps that nobody wants to run through again when they die. It's also supposed to not
teleport to anyone that is at the beginning of a map, incase anyone is idling...however it doesn't work
on every map.

Credit - This really shouldn't even be called "Shivaxi's" Teleporter as I had nothing to do with making this.
It was simply my idea. Credit for coding this goes to Ryuka and Lildude2o0o.

-Shivaxi
======================


The other nifty little mod is the iC Teleporter mod (http://www.freewebs.com/theezunreal/Mods/iCTele.zip)

Here's the ReadMe for that one:

====================
iC Teleporter mod
by Cheese

Installation:
Copy iCtele.u to your Unreal/System folder. If you want to use on a server, add
iCTele to your Server Packages.

How To Use:

In game, to create a teleporter, summon iCtele.iCTele. The Teleporter will be locked, until you summon a Destination for it.
To summon a Teleport Destination, summon iCtele.iCTeleDest.

You can summon multiple teleporters and destinations throughout the level. The teleporters and destinations link in order
that they were spawned. So if you summon 5 teleporters, then 5 teleport destinations, the first teleporter you summoned will
teleport you to the first destination you summoned, second to second, third to third, etc. If a teleporter is destroyed, it's
destination will be destroyed too. If a destination is destroyed, the teleporter that links to it will be locked again, and
the next destination you summon will be linked to that teleporter. To unlink and lock all the teleporters in the level,
type killall ictele.icteledest.

Credits:

Sonny[CW]: for the original idea for the teleporter.
Alchemy[iC]: for helping with the mod and suggestions.

Bugs/Glitches:
No known bugs or glitches.
====================

I know it's a little lazy to use teleporters like this, and I try to use them sparingly, but sometimes there are maps where you have to get through some kind of tricky jumping puzzle or line of moving lasers or other traps, where there is a pretty fair chance of dying repeatedly while getting the hang of the puzzle, and each time you respawn at the beginning of the level and then have to retrace your steps across a lengthy expanse of empty rooms and corridors just to get back to the "challenge" (in Single Player mode you would just create a saved game right before embarking on the challenge), and it sure is nice to be able to teleport right to the point where you left off, in that case...


Who is online

Users browsing this forum: No registered users and 1 guest

Copyright © 2001-2019 UnrealSP.org

Powered by phpBB® Forum Software © phpBB Limited