Page 5 of 7

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 05 Mar 2016, 05:19
by MrLoathsome
Oh yeah. :/ I knew there was a reason, just been so long since it came up forgot. :rolleyes:

Turns out this doesn't even seem to be a problem for most of the regulars
on the ecoop servers.
It appears that quite a number of them just let everything download from the
server and probably have never even heard of RMusicPlayer.
Most likely have never done anything to the Cache folder ever. :shake:

I am just gonna keep running it the way it is for now and inform any who have
troubles connecting due to RMusicPlayer mismatch etc of the 2 ways they
can still connect. I have these servers setup so that somebody with a
bone stock clean UT install can connect and everything will download. (Eventually.... :? )
(Or at least I had them that way. Plan on running that little test again soon.)

This is indeed an edge case I guess but that's ok.
I been to the edge. I stood and looked down.
Lost a lot of friends there. Got no time to mess around.
(Somebody set that to music....)

Don't waste a lot of time looking into this. Don't waste ANY time looking into this.

If you want to waste a bit of time, waste it looking at this:

It is my first weapons mod. I initially attacked the plasmabeam code just
to put a laser on flying sharks as a ranged attack. Halfway thru that project
I decided it had to be a gun also. So now it is.

Been testing it with both the old and new versions of EXU2 on the dedicated EXU
server for a few weeks now. It does not replace any of the EXU2 weapons, but
seems to be an excellent addition to the mix. Slides into the weapons list right
above the EnergyAR. (At least on my current client config)

And the custom skin papercoffee over at UT99 made for it, looks like it was made
for EXU.

Gun is useless in EXU at default settings of course. But it is infinitely adjustable.

I have been testing it in EXU with LaserLength setting at 100.
(Gives a solid beam of laser death about 8200uu in length.
Max. recommended for this version.)

Have the LaserDamage variable set at 880 currently for EXU use.
Eats thru lower health pawns, but does not insta-gib most of the dangerous ones.
(If the laser gun intrigues you, I also am working on Devilfish and flying
sharks that use the same adjustable laser as a ranged attack.)

Sorry to hijack your thread pimping my laser, but it fits in with EXU so well
I just had to do it.

And also. FANTASTIC fucking job with v6.0 !!! \o/ :tup:
Reviewed the thread here, and the minor hud stuff I noticed has already
been reported by others.

I played Shitstorm on the dedicated EXU server for 3 freaking hours after work today.
Very nice stuff. Only got myself a little more than 1/2 thru the map.
My score isn't very good. :lol: (And might be confusing gametracker. HA!!! :lol: )

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 13 Mar 2016, 04:07
by Buff Skeleton
So this may interest some of you:

Because I'm insane and can't seem to stop creating more work for myself, I decided Map 15 really, really needs a rewrite. So I've gutted everything but the terrain and the doomship flyby stuff and am building a completely new theme: a massive, creepy necropolis:

Gameplay will still be largely the same as before: survival mode, then chaos phase. But the layout is going to be opened up and fully non-linear. I actually kept all the pawns and items, but will probably be moving them around significantly and adding/removing stuff too. I also deleted the box secret with all the panels, but will definitely restore that kind of thing in a new form.

So far, so good! I am finding some really cool mausoleum ideas on Google. Spinning those off into more hellish constructions is where it gets interesting.

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 13 Mar 2016, 10:17
by UB_
Holy goddamn that actually really owns

Also lol blue/cyan hell symbols :)

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 15 Mar 2016, 01:19
by MrLoathsome
That does look nice.

Got a brief testing/bug report for you.

The easy one first:

Is it possible you have re-defined default variable Engine.Pawn NameArticle ?

Default declaration is: NameArticle=" a "

It seems as if you may have removed that leading space character. I think it needs to be there.
(If not, I got some other issue with a very old and simple mutator that just showed up now....)


Has anybody reported an issue with using the EXUTelefragAnything mutator online?

Getting nasty log files and client lockup when I tried that one on my EXU server.
Can run a few more tests and supply client log file info if this is something you are not aware of.
Server has no issues, but on the client screen is going black just before HUD should load.
UT does not crash immediately, but probably would if I let it sit there longer. Log file grows when the
screen is dark. Esc still gets you right to the menu which is sort of interesting....

(Haven't tested any of it offline, other than making sure the thing installed and the SP mission worked
when I first downloaded the new version.)

Also a question.

Is the EXUBarrelSwap mutator incompatible with the EXUItemSwappyThingy ?
Tested a few configs, but that barrelswap thing didn't seem to do much with any of them.

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 31 Mar 2016, 22:35
by UB_
Alright, I'm pretty sure the anti-xloc trigger doesn't work.

I have it up as a regular proximity trigger and as an activable trigger throughout Dispatcher (I suppose it works with the latter system).
I have a disc thrown in another area but if the XlocRecall actor is triggered nothing happens to the thrown disc. Not sure if it's broken or I'm missing something with the actor.

EDIT: Nevermind, got it to work phew. Seems like it only works with the regular UT xloc, not the EXU2 one.

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 01 Apr 2016, 00:00
by Buff Skeleton
It definitely should work with both - I'll check it out

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 01 Apr 2016, 02:03
by Buff Skeleton
Yep, release version is old enough that it didn't support subclasses because I didn't realize FindInventoryType only returned that EXACT class. I later updated it to look for both subclasses specifically, but tonight improved it further to use FindInventorySubclass, an EXUStaticFunction that came about later, to now properly find *any* Translocator subclass. So in theory, this will now support custom Translocators just fine!

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 23 Apr 2016, 05:39
by MrLoathsome
Well I was testing G59 The Limbo map for almost an hour this evening, with no server ssues.
Same instance of the game as I was playing last night, server is having no problems.
(Other than 5 accessed nones from some mover, which is a very clean log file really...)

At Hard difficulty it is considerably harder than medium, but the difference is about what it should
be. Not like the sudden extremely extreme jump that happens with some, but not all of the exu
maps. The Gatekeeper is killing me over and over atm, so I am not sure how long it
will take to finish this map.

I wouldn't waste a lot of time looking at that pupae code to track down that error in the log
posted in the other thread. When things go all haywire, the errors that crop up are almost
random. Sometimes the thing crashes before any useful info is written to the log file.

Of course tonight a whole different sort of crash occurred.
Got a GPF error on client side when I quit the game.
Server is still up and running. Nothing on the console or log to indicate any issue.

Here is the relevant part of the client log from the entire session:
► Show Spoiler

I like these 2 lines:
ScriptLog: Lord Naberius is kickin' yo ass right nah
DISCORDULOGGER: god damnit what the hell man

Log file is very very clean overall. Most of the warnings there are due to my horrible cow skin hack.
(I am going to yank the cowfix/nailfix packages off and adjust my skin next time the server needs
a restart.)

Perhaps this is an issue with garbage cleanup or some related function. Destroy(?).

Had one interesting lockup about 2 weeks ago, where the server didn't actually crash but
had the cpu usage in task monitor pinned at 100% and of course was not showing up online.
I noticed that the free memory available was ticking upwards in very small chunks, very slowly.
Watched that happen for almost 1/2 hour before I got tired of it and just restarted the thing.
No indication of abnormal memory allocation, but it was sure slow about giving it back.

Is it possible that all this is caused by the engine just overloading somehow due to the extremely
extreme amount of pawns the EXU maps have spawning at these difficulty levels?
Could the rate/frequency of more of them spawning also be an issue?
It it not something that happens right away. Seems to take at least an hour of play before
things start slowly getting weird.

I mean, I like my SP UT experience extreme. When AKcoop first came out I put it on my server
and have been running it 24/7 ever since at difficulty level 3. And added more stuff to it over the
years to make it more interesting and extreme even before EXU showed up.

But just to emphasize what I said in the other thread, the difference is the amount of pawns being
spawned is just nuts. Even when compared to the previous version(s) of EXU that I had online running
in Unreal difficulty, for several years.

The 3 hours I spent yesterday on Damnation and Shitstorm, I was pretty much being swarmed and
mobbed the entire time. It was too extreme. (I had nightmares about gasbags and pupae last night)

If I were you, I would try to scale back the extreme extremeness in the difficulty jump between
Medium and Hard before looking to closely at anything else. Perhaps these other issues will
just go away.

Don't think it is anything on my end. I haven't seen any logs from Japeezys EXU server, but
I know I made it restart a few times by just playing for a while at Hard or Unreal difficulty.

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 23 Apr 2016, 13:32
by UB_
FYI I still have rare crashes while playing EXU2 and G59. Usually happens when very late into a map (Map 1 probably, Map 5 shouldn't happen anymore), sometimes even caused by RMusicPlayer in music changing events.
Is jaypeezy running G59 maps on the server also or still not?

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 30 Apr 2016, 05:21
by MrLoathsome
Testing update.

The "Live" EXU server has only restarted itself once in the last several weeks. (8 days ago.)
That server is running in difficulty level 1 (Medium), and does have several extra mutators running.
I haven't even played that one myself for a while, as I have been on the "Test" server most of the time.

Been running the "Test" EXU server in Hard difficulty, and playing it a lot.
Sometimes in a completely stock/clean config, and other times with just 1 or 2 of the EXU
mutators and/or some of my own junk. (Testing several things at once is always fun....)

The presence or absence of the various mutators do not seem to have any significant effect on
CPU useage or the frequency of crashes/lockup at this difficultly level.
Been noticing the same thing with Damnation and Shitstorm as I mentioned before, but there is a
difference between the 2. Damnation builds up to a more steady CPU use, and seems less likely to
crash or lockup than Shitstorm. Which is a masterpiece. That was my favorite map since before GOTY.
It took me 4 1/2 hours to get thru that map yesterday. This was with the "Clean" config.
Brutal. Crazy. Makes my AKCoop server seem empty and boring.

I approve of your tweaks. Mostly.
(Are you sure you didn't skip Hard and just added Unreal and Extremely Unreal? As far as coop diff....)

Have made it all the way thru all the maps in several of the configs during testing so far.
But not all in the same session. (I gotta sleep, sometimes players show up and finish a map.)

Been accumulating a number of interesting log files. Most of which seem to have no useful info
regarding the occasional crash/lockup, but do contain references to a bunch of other minor glitches
which should be looked at. i.e. lines that appear to be notes to yourself saying "Fix this in UED".
Some of them... Overall log files are very clean.

Going to try and organize them all and maybe make a few notes about what what happening in the
game at that point, and if it is obvious to me, point you at the file or line(s) of code that need attention.

Expect a PM at some point. More testing is needed.....

*Edit: Re: RMusicPlayer.

On any of my servers, it only throws 4 accessed none warnings when the map starts.
*With any of the 3 versions of it that I be using. Including the dummy.
Other than the horror of requiring a DLL, it seems to work ok. Haven't suspected that of causing
a crash yet, but maybe I didn't check the log close when it did...
(I do like the music/sounds a lot. Have many speakers.)

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 09 May 2016, 03:17
by MrLoathsome
MrLoathsome wrote:Perhaps this is an issue with garbage cleanup or some related function. Destroy(?).

Had one interesting lockup about 2 weeks ago, where the server didn't actually crash but
had the cpu usage in task monitor pinned at 100% and of course was not showing up online.
I noticed that the free memory available was ticking upwards in very small chunks, very slowly.
Watched that happen for almost 1/2 hour before I got tired of it and just restarted the thing.
No indication of abnormal memory allocation, but it was sure slow about giving it back.

Update regarding the above weirdness. Had that happen about a week ago again.
This type of infrequent lockup generally seems to occur when ending the level.
My client UT was also locked up this time.

Instead of just killing it and restarting, I checked task manager, and my client was doing
the EXACT same thing as the server. Slowly releasing chunks of mem.

After about 10 minutes, client woke back up. Nothing at all in the log to indicate
anything was wrong.

So I just let the server sit to see what would happen, and in the hopes of getting something
useful in the log.

After 47 minutes the servers CPU use returned to normal and the server continued with the
map change.

Absolutely nothing in the log file to indicate anything was wrong, other than the 47 min
time difference between the end of shitstorm and the start of the next level.

Above info is just a FYI. I am thinking this might be a problem with coopgame2 rather
than anything EXU specific. Same sort of thing has occurred on the Ecoop servers
very infrequently in the past, although I would always just reset the thing when I noticed it.
Suppose the times I didn't notice, it just woke back up eventually leaving me with no clue
that it even happened.

Testing continues.....

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 11 May 2016, 23:33
by Buff Skeleton
Never ever had anything even remotely like that happen, and this is even when playing the supremely fucked up CA version of Shitstorm, so I think your server is just balls'd up somehow

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 18 May 2016, 07:45
by MrLoathsome
Well I think I found what my issue was.
Server and EXU are both fine.

Looks like I made a typo in my router config when getting things all restored
after the crash earlier this year.

One of the other UT servers on the box only had 1 port opened up instead
of the little block I usually give each one.
Not sure how it was even showing up in the server lists or working correctly but
it was.
It seemed to be just hi-jacking ports from the other UT servers which was
apparently confusing the hell out of them.

Sorry about wasting your time with this. If possible, just nuke these posts
out of your thread.

Will try to make up for it by attempting to fix the Pinata and/or BarrelSwap mutators.
(Unless you have already done so....)

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 18 May 2016, 22:31
MrLoathsome wrote:Will try to make up for it by attempting to fix the Pinata and/or BarrelSwap mutators.
(Unless you have already done so....)

I remember there was a bug in the Pinata mutator, when monsters kill you, you don't drop everything, just 1 weapon, well, i know this since i play in botmaches (With the MonsterHunt gametype on, buggy as shit, i hope the gametype is not the reason.)

I don't see what's the problem with the BarrelSwap, the mutator just replaces barrels to the awesome EXU variants.
Oh, idk, but... i've seen huge barrels somewhere... isn't it the BarrelSwap? Now i'm confused.

BTW, this is Open Beta, still bugs, for example there is a Accessed None from the HyperFlakker there, in your log, Loathsome.
Idk what's the problem with accessed nones, maybe they are too annoying and spams the log?

Re: == Version 6.00 [10-31-2014] Discussion ==

Posted: 19 May 2016, 09:34
by MrLoathsome
Well the BarrelSwap does not swap out the default wooden UnrealShare.Barrels.
It has no issues that I am aware of, but I was thinking of tweaking it a bit
so it would also do something with those.
I was thinking it would swap them, but then restore the wooden barrel skin so
that they did not look out of place on the map. Perhaps just add a bit of glow
so that player would know they were different. (They will find out soon enough....)

Well accessed nones are annoying and can spam the log, but they are what can
point you at problems in many cases.

For example if I have the Pinata mutator running every single time a player dies
there is exactly 1 accessed none error in the server log/console from the pinata.

Pretty sure I can track that down and fix it. I thought "Open" Beta was an invitation
to charge in and fix this sort of thing, and add stuff if possible.