Scout-kun is a lie... right?

Coronas won't show up when they get too close to decorations

For questions and discussion about UnrealEd, UnrealScript, and other aspects of Unreal Engine design.

Moderators: Semfry, zYnthetic, ividyon

dagmarsawayn
Pupae Pupae
Posts: 1
Joined: 24 Dec 2021, 09:51

Subject: Coronas won't show up when they get too close to decorations

Post Posted: 24 Dec 2021, 09:54

I'm trying to give monk and nali statues 'eyes' by putting tiny coronas in front of their faces. The coronas show up in the editor, but not in game. I tried it in UT's editor, and it worked fine, but it won't work with 227. It even worked in 224. Is there a setting I have to change to get it so that coronas won't disappear the moment I put them next to a decoration?

I'm using 227H and OpenGL, if that helps.

User avatar ividyon
Administrator Administrator
Posts: 2341
Joined: 12 Nov 2007, 14:43
Location: Germany
Contact:

Subject: Re: Coronas won't show up when they get too close to decorations

Post Posted: 24 Dec 2021, 10:02

In the Advanced Options, under Rendering -> OpenGL, are Coronas enabled?
UnrealSP.org webmaster & administrator

yrex
Skaarj Warrior Skaarj Warrior
Posts: 92
Joined: 07 Oct 2015, 11:19

Subject: Re: Coronas won't show up when they get too close to decorations

Post Posted: 24 Dec 2021, 15:59

Disable bBlockActors on the statues. Although that has the side effect that e.g. projectiles will pass through them.
e-mail: ampoyrex at wp dot pl

User avatar SteadZ
Skaarj Warlord Skaarj Warlord
Posts: 880
Joined: 04 Mar 2012, 10:52
Location: An error occurred. Please try again later.
Contact:

Subject: Re: Coronas won't show up when they get too close to decorations

Post Posted: 24 Dec 2021, 16:23

An alternative to the above suggestion (though it would render the map only playable under 227 - and the OP suggests that you want cross-compat?) would be to set the mesh to bUseMeshCollision instead of the traditional cylinder collision (I'm assuming Yrex is thinking along the same lines as I that the corona currently sits inside the radius of the mesh which is causing the disappearance issue)

Also on a slight tangent - any reason you're using 227h instead of 227i: the most recent version?
Image


Who is online

Users browsing this forum: No registered users and 3 guests

Copyright © 2001-2022 UnrealSP.org

Powered by phpBB® Forum Software © phpBB Limited