Page 1 of 1

UT jumpboots that last but turn on and off?

Posted: 04 Sep 2017, 08:08
by Ironword
Does anyone know of a jumpboot mod that lasts a long time (unlike the normal ones) but that you can turn on and off when playing UTSP?

I refuse to use the normal d---d jumpboots that run out after three jumps. I'm a clumsy jumper and whenever I have to use them to get somewhere, if I use the regular boots I have to save and then restart around ten times before I finally get up there. Then I finally decided that was just stupid--it wasn't worth the frustration, and I simply needed to use boots that didn't go bust after three jumps.

In Unreal 227 this is no problem; there are a number of nice jumpboot mods to choose from. Not so in UT, as far as I know, but I did find the really cool doubleJumpUT mod ( ... ut.122663/ -- I don't know where you could get it now, though, as it doesn't seem to be available at OldUnreal). Anyhow, this mod is not a fully viable solution for UTSP. It always works flawlessly in botmatch, but while testing UTSP maps I've run into a problem. UTSP mappers seem to love messing around with the default player scenario which gives you the impact hammer or dispersion pistol. Instead, all too often they force you to start with nothing and only later pick up the dispersion pistol (usually). When they do this, they completely destroy DoubleJumpUT. And it does not help to set PlayerPawn bCheatsEnabled True (or the longer unrealshare class command) and then manually summon the mutator. For some reason, if the mapper messed around with the normal starting pawn, doubleJumpUT is kaput, period, and nothing can be done about it.

So I'm trying to work around the problem by summoning the NW3 jumpboots, which you can configure to pretty much last forever. Unfortunately, they do not work as a normal inventory item in Oldskool. You can summon them, but when you pick them up, 1) they immediately become active, but 2) they do not show up in your inventory--so there is no way to ever turn them off. You have no choice but to get a vicarious headache by hitting the ceiling every time you just need to hop onto a box or something. Very annoying, and it really disrupts the game flow.

So is there a pair of modded UT jumpboots that lasts a long time but that does act like a normal inventory item, ie can be turned on and off?

Re: UT jumpboots that last but turn on and off?

Posted: 04 Sep 2017, 13:12
by watcher_of_the_skies
We are going to add a "custom" jumpboots pickup to the campaign you'd like to run
Open the first map of the campaign in the Editor.
You will see a menu on the top like: File-Edit-View-Brush...

Click Edit.
Then a new menu scrolls down. Look for this:Search for Actors.
Type PlayerStart there, then click OK.
The editor will instantly snap to the place your character starts.
There are 4 windows like: Top-Side-Front-3D.
Look for a "joystick" icon in the 3d window.

The next step is to find the Actor Browser.
It has an icon similiar to a chess pawn.
Search for PICKUPS. Extend it. Look for JUMPBOOTS. Click to it, then close the actor browser.
The next rhing you should do is to find that joystick like icon in the 3d window. Right click next to it to the ground. A new window comes up. Look for sth like... Add jumpboots here.
You'll see a jumpboot appearing on the ground. Click twice to it. A new window comes up:Jumpboots properties. You should see something like: charge. Type a lot of 9s into the box. Save the map.

Re: UT jumpboots that last but turn on and off?

Posted: 04 Sep 2017, 13:17
by watcher_of_the_skies
Method 2.

Start the game and choose the map you'd like to play.
Bring up the console any type this: summon jumpboots.
A "jumpboots" pickup should instantly appear in front of you.
Don't pick it up.
Bring up the console again and type: editactor jumpboots.
A window should emerge. Search for charge. Alter it to 9999999. Exit the window and pick up the boots

Re: UT jumpboots that last but turn on and off?

Posted: 05 Sep 2017, 02:51
by Ironword
Watcher--thanks a ton for trying to help. Unfortunately neither method is working for me.

Method 1:
Something is wrong with my UnrealEds. I have Unreal Gold with both UT and UG installed, UT patched to 436 and Unreal to 227i, but when I attempt to open UnrealED from UT/System I get an error saying it can't find package thesisbase. I did a search on my UT disks and there is no such package to be found.

I can open UnrealEd from UnrealGold/System but it still does no good. There, when I load a map, nothing shows up. UnrealEd remains a blank white window with nothing in it. I think when I open a map the levels are actually loading because the title bar shows the name and path of the map, but I do not have any "4 windows like: Top-Side-Front-3D."

EDIT: I created a new install and have working UT UnrealEd. Or maybe just quasi-working, because I tried this method on 4 of the maps that bollox DoubleJumpboots and it didn't work in any of them: badcargo, 9dragonsintro, FotWmap1-Skaarjbase, Skyfalls, and RTNP Ultimate Edition, viz:

1. Badcargo opens and there's a lot of stuff on the screen. The map is definitely open. Then I do Edit | Search for actors and type "playerstart" in the box, then highlight and double-click (there's no "OK"), and the start of the map is now shown in the 4 windows (I can recognize the scene even in the outlines). But can't do anything else because the Search for actors dialog freezes. UnrealEd crashes and have to use task manager to terminate it. Tried this 4 different times, same result.

2-4: when I attempt to open 9dragonsintro, FotWmap1-Skaarjbase, and Skyfalls, nothing happens. There is no sign that the maps are loading like there is with badcargo, and nothing shows up in the 4 windows. Nada, zilch. UnrealEd's title bar says that each map is loaded, but there's nothing there. And when I do Edit | Search for actors and type "playerstart", there is no result. This behavior is the same for all three of these maps.

5. RTNP Ultimate Edition: I thought I'd better try a campaign instead of just single maps. Here I replicated both of the above results. When opening maps intro1, intro2, and interintro, I replicated the result in which nothing at all happened. When I opened map nevec, which is the first map in which you really do much, the map does seem to have opened and there was a bunch of stuff on the screen--and just as with badcargo, doubleclicking the "playerstart" resulted in a crash and I couldn't proceed.

So method 1 doesn't look like it will ever work for me--that's a bunch of different maps, all failing for one reason or another. Or is my UnrealEd missing something? (But remember, my UT is patched to 436, so it's fully up to date.)

Method 2:
I can summon the jumpboots but when I type the editactor string I get the message, "bad or missing class or name". I have tried this with both unreali.jumpboots and ut_jumboots. I.e. since I'm playing in UT, I summoned both types of jumpboots and tried "editactor unreali.jumpboots" and "editactor ut_jumpboots". Nothing works. I get the "missing name" message for all of them, tried in all five of the above-mentioned maps. There must be something else I'm not doing?

Re: UT jumpboots that last but turn on and off?

Posted: 05 Sep 2017, 03:34
by Buff Skeleton
You need to use "editactor class=<classname>" rather than just editactor, and then you should be set.

Re: UT jumpboots that last but turn on and off?

Posted: 05 Sep 2017, 04:34
by Ironword
OK, I got the editing list window, and it worked! I found Inventory | Charge. Thanks very much!

I can certainly get on with this solution. If you do have any further advice about method 1 with UnrealED, however, I'd be very grateful as I'd love to just go through the procedure it once for an entire campaign (as in RTNP Ultimate edition). I'm also just curious as to why the levels which appear not to load aren't loading--or at least why their stuff fails to appear onscreen.