Did you know? All of these messages will likely be replaced before release.

[u227i/j] The Descent Release Thread

For discussion and promotion of Unreal Engine single-player campaigns, mapping projects and total conversions.

Moderators: ividyon, Semfry, zYnthetic

AndriHK96
Pupae Pupae
Posts: 9
Joined: 30 Dec 2021, 16:34

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 30 Dec 2021, 23:34

However I tried to open the other maps and the error is always the same. There appear to be no other additional ones.

User avatar ebd
Trustee Member Trustee Member
Posts: 436
Joined: 05 Apr 2008, 19:08
Contact:

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 30 Dec 2021, 23:43

AndriHK96 wrote:I thank you for the answer. I have viewed the log file and it seems that the problem is importing a texture from the "DecayedS" package

DecayedS is a stock texture package. Do you have the same issue with stock maps that use it? For example, DmAriza and Terraniux

The SHA256 sum of DecayedS.utx should be: EAF77E6320477A589BF9C05BE572537A3DF144105D3AE3186546CA405924D797
If you've modified the package or it has become corrupted, you may wish to reinstall Unreal.

yrex
Skaarj Warrior Skaarj Warrior
Posts: 93
Joined: 07 Oct 2015, 11:19

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 31 Dec 2021, 01:07

Try replacing DecayedS with a different version (e.g. SD instead of HD, different version of HD...)
e-mail: ampoyrex at wp dot pl

AndriHK96
Pupae Pupae
Posts: 9
Joined: 30 Dec 2021, 16:34

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 31 Dec 2021, 17:30

Good evening and happy new year to all :tup: . I have noticed that "DecayedS" is a package of the original game, and precisely it is part of the new HD set of AHaigh01 version 3.0 (not 4K), which by now on the Google site "Unreal HD Textures" I can't find anymore together with the Standard version.
Its SHA256 is "c5cb76d3a445af6592d2014c4d3ac166a5d98c57d94e087a12d8d56b0854d501", but all the other maps from the original game start smoothly, including "DmAriza" and "Terraniux". I have not modified the package. Also I tried looking for the affected texture "Palette DecayedS.Palette1" inside the "DecayedS" package in the Unreal Editor and it doesn't show up. I don't know if it was included in the original game file and I can't even verify it by seeing the full set of package textures from the "UnrealTexture" site, which is no longer found. Does anyone of you have a link to download the Standard version of AHaigh01 3.0?

User avatar ividyon
Administrator Administrator
Posts: 2346
Joined: 12 Nov 2007, 14:43
Location: Germany
Contact:

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 31 Dec 2021, 23:57

You'd be looking for the 3.5 version, not the 3.0, which features various improvements.

https://sites.google.com/view/unrealhdtextures/home
UnrealSP.org webmaster & administrator

AndriHK96
Pupae Pupae
Posts: 9
Joined: 30 Dec 2021, 16:34

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 01 Jan 2022, 18:19

Ok, I'll try, but the textures are only in 4K...
My hardware isn't very powerful: I have an Nvidia Geforce GTX 1050 as a video card and an HP 2159m Full HD screen. For the game I also installed Lightning_Hunter's HD Skins 3.1, and I'm afraid that together with these textures the gameplay will tend to jerk in action scenes. Previously, out of curiosity, I had already tried to install the 4K 3.0 version for the DirectX 11 renderer, and I had this problem. I also have a nearly full 223 GB SSD and this will put even more strain on the graphics fluency.
For now, I don't have the immediate need to upgrade my PC, as most of the programs I use work fine.
Personally I would have preferred that the Standard and HD 3.5 versions had also been released in order to guarantee the safe use of textures even on peripherals with lower performance.
Anyway, I'll try and then I'll let you know if I solve the problem...
In the meantime, thank you all the same for your help :tup:

User avatar ebd
Trustee Member Trustee Member
Posts: 436
Joined: 05 Apr 2008, 19:08
Contact:

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 01 Jan 2022, 19:24

AndriHK96 wrote:it is part of the new HD set of AHaigh01 version 3.0 (not 4K)

HD textures and any other modifications that modify or replace stock packages cause a lot of headaches and compatibility problems and frequently deviate from the author's aesthetic intent in maps. I strongly recommend against using any mod that replaces or modifies stock packages. As tempting as they may be, their impact on the player experience is often for the worse.

User avatar Psychomorph
Skaarj Lord Skaarj Lord
Posts: 157
Joined: 17 Jul 2008, 16:46

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 01 Jan 2022, 23:19

I try to run this through UT (Infiltration 2.9 Co-op), but get the error message "Can't find Function in file 'Function Engine.Actor.TriggerEvent'".

Any idea for a solution?
Image

User avatar SteadZ
Skaarj Warlord Skaarj Warlord
Posts: 881
Joined: 04 Mar 2012, 10:52
Location: An error occurred. Please try again later.
Contact:

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 01 Jan 2022, 23:32

See the first post (and readme):
Should have gone to Specsavers wrote:This will only work in Unreal patched to 227i/227j, no plans to port to other platforms at present.
Image

User avatar Mister_Prophet
Red Nemesis Leader Red Nemesis Leader
Posts: 3069
Joined: 11 Nov 2007, 23:30
Location: Lost in Oraghar

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 01 Jan 2022, 23:33

Psychomorph wrote:I try to run this through UT (Infiltration 2.9 Co-op), but get the error message "Can't find Function in file 'Function Engine.Actor.TriggerEvent'".

Any idea for a solution?


I don't believe The Descent is compatible with UT. Many of the features are 227i specific (or 227j). What Steadz said :o
Last edited by Mister_Prophet on 01 Jan 2022, 23:41, edited 1 time in total.

User avatar Psychomorph
Skaarj Lord Skaarj Lord
Posts: 157
Joined: 17 Jul 2008, 16:46

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 01 Jan 2022, 23:39

SteadZ wrote:See the first post (and readme):
Should have gone to Specsavers wrote:This will only work in Unreal patched to 227i/227j, no plans to port to other platforms at present.


I see. So 227i/j is basically another engine than U/UT?
Image

User avatar Mister_Prophet
Red Nemesis Leader Red Nemesis Leader
Posts: 3069
Joined: 11 Nov 2007, 23:30
Location: Lost in Oraghar

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 01 Jan 2022, 23:53

It has unique features and engine upgrades not present in base Unreal or UT. The Descent uses specific elements of this patch, including but not limited to static meshes and emitters. There is also custom code dependent on 227 as well.

The good news is that the patch is free. You only need a copy of Unreal or Unreal Gold.

User avatar ebd
Trustee Member Trustee Member
Posts: 436
Joined: 05 Apr 2008, 19:08
Contact:

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 02 Jan 2022, 07:15

Psychomorph wrote:
SteadZ wrote:See the first post (and readme):
Should have gone to Specsavers wrote:This will only work in Unreal patched to 227i/227j, no plans to port to other platforms at present.


I see. So 227i/j is basically another engine than U/UT?

Kind of. UT already had slight engine improvements over U1, although both are thought of as "UE1". Some years back, the 227 team was given access to the source code for U1 and has added some new features and mapping tools, such as static meshes, emitters, a much more stable editor, increasing the node limit of maps, and more. It's still a lot closer to UE1 than UE2. A huge amount of care has been given to ensuring everything created under 226 and below remains compatible with 227, but the nature of these new features means content using these new features is not compatible with 436 (UT99). I believe the 469 UT patch is focused only on stability and bug fixes and is not looking to add new features like the 227 patch has.

This particular pack was created with the intent on using the new features in 227, so 227i (very stable version) or 227j (unstable beta version) is required for this pack.

AndriHK96
Pupae Pupae
Posts: 9
Joined: 30 Dec 2021, 16:34

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 02 Jan 2022, 15:33

Sorry, I forgot to ask you an obvious question: but the campaign works for you with the textures of AHaigh01? And if so, what version do you use?

yrex
Skaarj Warrior Skaarj Warrior
Posts: 93
Joined: 07 Oct 2015, 11:19

Subject: Re: [u227i/j] The Descent Release Thread

Post Posted: 02 Jan 2022, 18:04

For me, it started to work when I used DecayedS version with SHA256=7D3241D83F7685549A37ADD905DE83FF3E726F17D742221A4C7DBC24D2F6527C, downloaded probably from here: https://www.moddb.com/games/unreal/addo ... d-textures
e-mail: ampoyrex at wp dot pl

Previous Next

Who is online

Users browsing this forum: No registered users and 2 guests

Copyright © 2001-2022 UnrealSP.org

Powered by phpBB® Forum Software © phpBB Limited