Birds fly. Sun shines. And brother? Brutes shoot people.

[V1.1 RELEASED] The Vale: Evelyn [UT]

For discussion and promotion of Unreal Engine single-player campaigns, mapping projects and total conversions.

Moderators: ividyon, Semfry, zYnthetic

User avatar Mister_Prophet
Red Nemesis Leader Red Nemesis Leader
Posts: 3066
Joined: 11 Nov 2007, 23:30
Location: Lost in Oraghar

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 28 Jun 2022, 15:50

Diego96 wrote:Shame we didn't get the chance to play it in a comfy snow setting.


You will. The location is revisited in Savage Land, albeit at a later timeframe in colder weather. Fashahhh has done an amazing job bringing the Vale full circle. Truly a fantastic level, through in through.

User avatar fashahhh
Skaarj Assassin Skaarj Assassin
Posts: 100
Joined: 09 Dec 2007, 14:47

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 02 Jul 2022, 21:41

Thanks guys! :)

I'm looking to release 1 last update to include 227 compatibility (with Botpack) and fix a few minor things.
I have got it running in 227 but need to replace a lot of Oldskool dependencies.

User avatar Aspide
Skaarj Scout Skaarj Scout
Posts: 41
Joined: 14 May 2021, 23:08

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 02 Jul 2022, 23:29

Wow, I can't believe I haven't played this map until now, it's fantastic :D . This is as good as you can get with BSP terrain (I wonder how much time it took to do the terrain alone, I know that it would take me ages to do something like this). This map reminds me of ONP, without the leet stuff :) . My only two complains is that first the FPS are really bad in the first area, especially when you look at the tower from afar, it has to do with lighting because when you deactivate lighting the FPS are good, something to do with the light effects used in the tower and also the fact that the water is transparent (turning the water to non-transparent solves the FPS issue however it ruins the beauty of the map :cry: ), and the second complain is that as much as I like the first song, it plays again later in the map, the problem is that the song plays in two very long sections, so the song gets repetitive especially the first time you play this map. But besides that this map is great, Unreal Engine 1 at its finest :tup:
Somewhere in Nevada...

User avatar fashahhh
Skaarj Assassin Skaarj Assassin
Posts: 100
Joined: 09 Dec 2007, 14:47

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 03 Jul 2022, 10:34

Thanks Aspide. I did experiment taking away the water lighting effects & non-transparent water (which did improve the performance) but as it was only for a few moments visuals won through in the end. I was hoping it was more my piece of crap PC not being able to cope than anything.

User avatar fashahhh
Skaarj Assassin Skaarj Assassin
Posts: 100
Joined: 09 Dec 2007, 14:47

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 24 Jul 2022, 20:20

Hi all,

I have got this working under 227j however I'm having a few problems so was wondering if anyone can help?

1. The end level teleport to 'unreal.unr' no longer functions. I load the same level up in UT and it works. But load it up in 227j and nothing happens. The teleport is supposed to run on the dispatcher after Evelyn's name appears. I'm currently using the following teleport destination 'Unreal#exitvale?peer'.

2. When choosing 'CoopGame UnrealShare' the map is not loading with the Coop assets (again it does in UT). It simply just respawns weapons but none of the Coop filters work. Is there another option I should be choosing or is there another way of starting coop games?

3. Although the map works in 227j, for some reason it crashes out the Editor. I try to load the map and it simply closes the editor with no error messages. Start a new game in Unreal and there it is and plays fine. All changes I'm having to make in UT and copy it over to 227j at the moment. Has anyone else encountered this? Could it be to do with 227 Botpack maybe?

User avatar Kajgue
N-Team Leader N-Team Leader
Posts: 253
Joined: 12 Nov 2007, 18:07
Location: London, UK
Contact:

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 24 Jul 2022, 20:37

Heya Fashahhh,

Hmm, I'm not sure about these issues tbh, but if you're on Discord it might be a good idea to join the OldUnreal discord server and ask these questions there if there are no available answers after some time. The 3rd issue for sure I would bring up with Oldunreal, as it sounds definitely like something that needs fixing with 227.

Sorry i couldn't be of too much help yet, but if i find out anything else I'll let you know.
N-Team leader
The Silver Blades clan chief
Image

User avatar Aspide
Skaarj Scout Skaarj Scout
Posts: 41
Joined: 14 May 2021, 23:08

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 24 Jul 2022, 22:21

What about 227i?, if it works in that one then it means either 227j is causing the problem or the 227 botpack is incompatible with 227j....

Try opening the 227 botpack files in the editor, if the editor crashes or closes then that means the 227 botpack doesn't work in 227j
Somewhere in Nevada...

Masterkent
Skaarj Scout Skaarj Scout
Posts: 22
Joined: 08 Oct 2016, 19:26

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 24 Jul 2022, 22:31

fashahhh wrote:1. The end level teleport to 'unreal.unr' no longer functions. I load the same level up in UT and it works. But load it up in 227j and nothing happens. The teleport is supposed to run on the dispatcher after Evelyn's name appears. I'm currently using the following teleport destination 'Unreal#exitvale?peer'.

As far as I remember, that teleporter has very big CollisionRadius and CollisionHeight, and players may have troubles with touching it. My B227_MapFix.ini should already have a hack fix for this particular map exit (if you run this map with mutator B227_MapFix.B227_MapFix using the corresponding ini file, the teleporter should work).

fashahhh wrote:2. When choosing 'CoopGame UnrealShare' the map is not loading with the Coop assets (again it does in UT). It simply just respawns weapons but none of the Coop filters work. Is there another option I should be choosing or is there another way of starting coop games?

Make sure that you use UnrealShare.CoopGame game class on a server (dedicated or listen) rather than in standalone game mode. Also note that filters won't work on bStatic or bNoDelete actors, except for a few classes (such as movers) that provide special workarounds to support filtering under such conditions.

fashahhh wrote:3. Although the map works in 227j, for some reason it crashes out the Editor. I try to load the map and it simply closes the editor with no error messages. Start a new game in Unreal and there it is and plays fine. All changes I'm having to make in UT and copy it over to 227j at the moment. Has anyone else encountered this? Could it be to do with 227 Botpack maybe?

I don't have such troubles with the version of your map that I have. You can try to choose a different renderer, maybe it could help.

User avatar Kajgue
N-Team Leader N-Team Leader
Posts: 253
Joined: 12 Nov 2007, 18:07
Location: London, UK
Contact:

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 25 Jul 2022, 20:34

Actually, something to ask about issue 3 ...

Do any of your viewports, be it the 3d world views, 2d views, texture browser or mesh browser mix normal Opengl and XOpengl? I had such an issue a long time ago also, where the editor would crash if i had both renderers enabled at the same time in multiple viewports.

Though if it's just the specific map crashing, perhaps that's not the case. But maybe it doesn't crash on a blank map as it's not rendering anything.

It's worth checking :tup:
N-Team leader
The Silver Blades clan chief
Image

User avatar Psychomorph
Skaarj Lord Skaarj Lord
Posts: 156
Joined: 17 Jul 2008, 16:46

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 25 Jul 2022, 22:26

Download link in the 1st post doesn't work for me. Where could I download?
Image

User avatar Diego96
Skaarj Lord Skaarj Lord
Posts: 161
Joined: 13 Apr 2014, 19:36
Location: South 'Merica

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 26 Jul 2022, 18:01

Psychomorph wrote:Download link in the 1st post doesn't work for me. Where could I download?

http://medor.no-ip.org/Maps/SinglePlaye ... le_1.1.zip
M'nali

User avatar fashahhh
Skaarj Assassin Skaarj Assassin
Posts: 100
Joined: 09 Dec 2007, 14:47

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 26 Jul 2022, 22:29

Thanks for the responses.

Masterkent wrote:As far as I remember, that teleporter has very big CollisionRadius and CollisionHeight, and players may have troubles with touching it. My B227_MapFix.ini should already have a hack fix for this particular map exit (if you run this map with mutator B227_MapFix.B227_MapFix using the corresponding ini file, the teleporter should work).


Is there another workaround for this? I would rather people didn't have allow a mutator for the map to end?
I've also tried this in 227i and get the same problem with an additional issue where the cryopod doesn't open (it opens in 227j though).

Masterkent wrote:Make sure that you use UnrealShare.CoopGame game class on a server (dedicated or listen) rather than in standalone game mode. Also note that filters won't work on bStatic or bNoDelete actors, except for a few classes (such as movers) that provide special workarounds to support filtering under such conditions.


Ah cheers, I was using the coop under single player when I should be using the multiplayer tab then selecting co-op game unrealshare. It seems to load as a coop game ok this way with the coop assets.

Masterkent wrote:I don't have such troubles with the version of your map that I have. You can try to choose a different renderer, maybe it could help.


Kajgue wrote:Actually, something to ask about issue 3 ...

Do any of your viewports, be it the 3d world views, 2d views, texture browser or mesh browser mix normal Opengl and XOpengl? I had such an issue a long time ago also, where the editor would crash if i had both renderers enabled at the same time in multiple viewports.

Though if it's just the specific map crashing, perhaps that's not the case. But maybe it doesn't crash on a blank map as it's not rendering anything.

It's worth checking :tup:


Yes I've tried different renderers and still the same problem. It opens other maps fine in the editor. I've changed the renderer to the same as in game OpenGLDrv.OpenGLRenderDevice (all windows the same renderer) and still it just closes the editor. The same map loads fine in 227i with the same renderer.

Masterkent
Skaarj Scout Skaarj Scout
Posts: 22
Joined: 08 Oct 2016, 19:26

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 27 Jul 2022, 00:42

fashahhh wrote:
Masterkent wrote:As far as I remember, that teleporter has very big CollisionRadius and CollisionHeight, and players may have troubles with touching it. My B227_MapFix.ini should already have a hack fix for this particular map exit (if you run this map with mutator B227_MapFix.B227_MapFix using the corresponding ini file, the teleporter should work).

Is there another workaround for this? I would rather people didn't have allow a mutator for the map to end?

The mutator only reduces CollisionRadius and CollisionHeight of that teleporter. You could lower these properties directly in your map, unless you have specific reasons to keep them as large as they are.

fashahhh wrote:I've also tried this in 227i and get the same problem with an additional issue where the cryopod doesn't open (it opens in 227j though).

That's a bug in 227i - it doesn't allow using states whose name is the same as the class name. Cryopods could be fixed for 227i with some scripting, but I think that it's not a big issue.

fashahhh wrote:Yes I've tried different renderers and still the same problem. It opens other maps fine in the editor. I've changed the renderer to the same as in game OpenGLDrv.OpenGLRenderDevice (all windows the same renderer) and still it just closes the editor. The same map loads fine in 227i with the same renderer.

That's interesting. Does it crash when loading version 1.1 of the map?

User avatar fashahhh
Skaarj Assassin Skaarj Assassin
Posts: 100
Joined: 09 Dec 2007, 14:47

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 27 Jul 2022, 21:37

Thanks Masterkent

Masterkent wrote:The mutator only reduces CollisionRadius and CollisionHeight of that teleporter. You could lower these properties directly in your map, unless you have specific reasons to keep them as large as they are.


Brilliant thanks, that seems to have worked. I've reduced the collision height significantly and reduced the radius slightly. It has to be quite a large radius as the player can run beyond the collision radius during the scripted Cryopod sequence thus not triggering the end level.

Masterkent wrote:That's interesting. Does it crash when loading version 1.1 of the map?


This version is pretty much the 1.1 version with only minor changes & removed Oldskool dependency. As said previously it loads fine in UT Ed 2.0 & 227i 2.1.

As long as it plays in the main game i'm not too concerned. Expect the updated version within the next few days.

Thanks again!

User avatar fashahhh
Skaarj Assassin Skaarj Assassin
Posts: 100
Joined: 09 Dec 2007, 14:47

Subject: Re: [V1.1 RELEASED] The Vale: Evelyn [UT]

Post Posted: 30 Jul 2022, 08:56

Ok don't know why I didn't before, but checking the log it appears to be the wet texture in Indus6.utx that's crashing the editor. I tested loading up DM-KGalleon and get the same problem, I also tested another UT-DM map without the wet texture and it loaded fine.

Critical: UWetTexture::InitFractical
Critical: (WetTexture Indus6.WetStuff.WetBeams1)
Critical: UFractalTexture::PostLoad
Critical: UObject::ConditionalPostLoad
Critical: (WetTexture Indus6.WetStuff.WetBeams1)
Critical: PostLoadObjects
Critical: UObject::EndLoad
Critical: UObject::LoadPackage
Critical: UEditorEngine::Exec
Critical: (MAP LOAD FILE="D:\Games\Unreal\Maps\SP-Vale_Evelyn_227.unr")
Critical: FileOpen
Critical: WEditorFrame::OnCommand
Critical: WWindow::WndProc
Critical: WWindow::StaticProc
Critical: (Message=WM_COMMAND)
Critical: Critical error in window message!
Exit: Shutdown multi-threading took 0.00 MS
Critical: Error reentered: Error on main thread

Previous Next

Who is online

Users browsing this forum: No registered users and 5 guests

Copyright © 2001-2022 UnrealSP.org

Powered by phpBB® Forum Software © phpBB Limited