Could be asleep, typing random messages instead.

fashahhh's mapping problems

For questions and discussion about UnrealEd, UnrealScript, and other aspects of Unreal Engine design.

Moderators: Semfry, ividyon

User avatar fashahhh
Skaarj Assassin Skaarj Assassin
Posts: 110
Joined: 09 Dec 2007, 14:47

Subject: fashahhh's mapping problems

Post Posted: 16 Jan 2021, 20:45

Hi All,

Hope you are all safe.

I'm having an issue with Gasbags not roaming once they are spawned. Using the Trench map as an example which has no path nodes, the gasbags spawn in and immediately roam the area. I thought this may be due to the Creature Factory orders being set to 'Roaming' however they are all set to 'Attacking' but automatically roam the area anyway.

When I try the same thing in my map they just all stay put. The Gasbags I'm using are high up out of reach of path nodes so I just want them to wander. I think to my knowledge I've copied all properties from the spawned Gasbags in the Trench however mine just won't move unless provoked. I've tried setting their orders to both Roaming & Attacking and I get the same outcome.

Is there something I'm missing?
Last edited by fashahhh on 13 May 2022, 21:40, edited 3 times in total.

Krull0r
Skaarj Warrior Skaarj Warrior
Posts: 70
Joined: 04 Jun 2014, 22:18

Subject: Re: Creature Factory Roaming Gasbags Problem

Post Posted: 21 Jan 2021, 15:24

Hello :)

I'm fine so far.

Try Orders "Wandering" that makes them fly randomly around.

User avatar fashahhh
Skaarj Assassin Skaarj Assassin
Posts: 110
Joined: 09 Dec 2007, 14:47

Subject: Re: Creature Factory Roaming Gasbags Problem

Post Posted: 24 Jan 2021, 17:36

Thanks very much Krull0r. It works! Can't believe I didn't realize you could give that order :oops:

Krull0r
Skaarj Warrior Skaarj Warrior
Posts: 70
Joined: 04 Jun 2014, 22:18

Subject: Re: Creature Factory Roaming Gasbags Problem

Post Posted: 24 Jan 2021, 18:00

You're welcome. You can also take a look in the ScriptedPawns scripts and check the "States"

Here is an other handy tip for the creature factory. If you trigger it with a trigger actor enemies won't hunt for you. They only hunt for the player when the player touches the creature factory.

nikosv
Skaarj Berserker Skaarj Berserker
Posts: 284
Joined: 03 Aug 2008, 23:07
Contact:

Subject: Re: Creature Factory Roaming Gasbags Problem

Post Posted: 01 Feb 2021, 22:50

^That's tremendously helpful. What a strange quirk.
Current Project: None. WTFs2 had to go to sleep, RIP.

I still sometimes sculpt PS2-style terrain by hand with Blender 3. Some passions always linger.

User avatar fashahhh
Skaarj Assassin Skaarj Assassin
Posts: 110
Joined: 09 Dec 2007, 14:47

Subject: fashahhh's mapping problems: Co-op & Patrolling issue

Post Posted: 07 Mar 2021, 15:02

Rather than keep posting new threads I thought I might rename this one.

I seem to have another problem. I'm introducing Co-op into the Vale map however have run into an issue where the patrolling enemies have stopped patrolling. I have run through the co-op features added and have isolated the cause to a teleporter that appears behind the forcefield to the final arena so other players can access it when the forcefield is up.

Essentially the forcefield that pops up when the player enters the boss arena has a visible teleporter attached to it which is filtered out of single player. The strange thing is if the teleporter is set to single player as well, all the enemies patrol as normal. If it is set to filtered out, they no longer patrol and just stand around.

I've tried re-doing the visible teleporter, changing to a static teleporter that switches on, re-building paths & a full rebuild but I get the same problem. So it has to do with the filtering.

Obviously I don't want there to be a teleporter showing behind the forcefield when playing in single player.

Has anyone else encountered this type of issue when filtering out for co-op?

UB_
Nali Priest Nali Priest
Posts: 7961
Joined: 11 Nov 2007, 21:00

Subject: Re: fashahhh's mapping problems: Co-op & Patrolling issue

Post Posted: 07 Mar 2021, 15:05

Filtering any navpoint actor, including teleporters, will always crash the game during saves, and could possibly lead to other issues. Instead, filter a trigger that activates the teleporter.
ImageImage

User avatar fashahhh
Skaarj Assassin Skaarj Assassin
Posts: 110
Joined: 09 Dec 2007, 14:47

Subject: Re: fashahhh's mapping problems: Co-op & Patrolling issue

Post Posted: 07 Mar 2021, 17:21

Brilliant thanks UB that's worked. I had to attach a filtered scaled sprite to the forcefield for a teleporter indicator in co-op but everything works as it should now. Just need to do some playtesting and it all should be ready.

User avatar fashahhh
Skaarj Assassin Skaarj Assassin
Posts: 110
Joined: 09 Dec 2007, 14:47

Subject: Re: fashahhh's mapping problems

Post Posted: 10 Oct 2023, 18:20

Hi All,

Was wondering if someone can help? After a long days mapping on Sunday. I've tried loading up UnrealEd (2.0) yesterday & today and for some reason it gets up to the below then just shuts down without any error messages. I've tried a separate UT install in a different folder and it's doing the exact same thing. Has anyone else encountered this problem before?

This is as far as it gets, then closes:
Image

User avatar makemeunreal
Skaarj Elder Skaarj Elder
Posts: 1299
Joined: 20 Mar 2011, 09:20
Contact:

Subject: Re: fashahhh's mapping problems

Post Posted: 11 Oct 2023, 11:58

Try deleting the UnrealED.ini from the System folder.
"They let us go about our business here, but it is a farce. I know that they are watching us, controlling us. I believe that this once safe haven is as deadly as the surface planet below."

User avatar fashahhh
Skaarj Assassin Skaarj Assassin
Posts: 110
Joined: 09 Dec 2007, 14:47

Subject: Re: fashahhh's mapping problems

Post Posted: 12 Oct 2023, 13:20

makemeunreal wrote:Try deleting the UnrealED.ini from the System folder.


Hi. Yes I tried that but it still does the same thing. The main game .exe opens up fine it's just the editor. I also installed a clean version on another drive and i'm getting the same problem. I'm wondering if it's a windows registry issue or something?

User avatar Mister_Prophet
Red Nemesis Leader Red Nemesis Leader
Posts: 3108
Joined: 11 Nov 2007, 23:30
Location: Lost in Oraghar

Subject: Re: fashahhh's mapping problems

Post Posted: 13 Oct 2023, 15:49

I'm assuming you ran the 436 patch again too, right? That has helped reset my Ed in the past.


Who is online

Users browsing this forum: No registered users and 4 guests

Copyright © 2001-2024 UnrealSP.org

Powered by phpBB® Forum Software © phpBB Limited