Could be asleep, typing random messages instead.

How do I disable blob shadows in UT99 Directx9?

For gameplay advice and broader discussion of single-player Unreal including custom maps, mods and mutations that alter the game.

Moderators: Semfry, zYnthetic, ividyon

Diego96
Skaarj Warrior Skaarj Warrior
Posts: 51
Joined: 13 Apr 2014, 19:36
Location: South 'Merica

Subject: How do I disable blob shadows in UT99 Directx9?

Post Posted: 14 Aug 2017, 00:59

I wanted to play custom campaigns through oldskool but those shadows annoy me at times. I don't know what line in the .ini controls them but I know they can be disabled in DX11 mode.

medor
Skaarj Lord Skaarj Lord
Posts: 152
Joined: 07 Jun 2009, 22:58

Subject: Re: How do I disable blob shadows in UT99 Directx9?

Post Posted: 15 Aug 2017, 13:39

VolumetricLighting=False

User avatar Lightning Hunter
Skaarj Elder Skaarj Elder
Posts: 1257
Joined: 11 Nov 2007, 22:12
Location: Pervert.

Subject: Re: How do I disable blob shadows in UT99 Directx9?

Post Posted: 16 Aug 2017, 04:57

medor wrote:VolumetricLighting=False


I don't believe Volumetric Lighting impacts shadows. In fact, I think shadows appear in D3D but not OpenGL, and there may not be a setting for them. Volumetric Lighting turned off will disable ALL the incredibly awesome fog effects in the game. Map packs like Redeem Your Space make really good use of fog, and it would be a shame to lose it. I always tell people to make sure they have VolumetricLighting set to True, otherwise they are missing out on a lot. Just take a look at the ventilation shafts in Vortex Rikers with VolumetricLighting on vs. off. The difference is huge. Certain parts of Unreal look like garbage without fog.
For High-Res Unreal skins, click here.
For the RTNP "Ultimate Edition" HD, click here.

Image

User avatar Buff Skeleton
>:E >:E
Posts: 4097
Joined: 15 Dec 2007, 00:46

Subject: Re: How do I disable blob shadows in UT99 Directx9?

Post Posted: 16 Aug 2017, 18:29

Yeah, Volumetric Lighting is fog. The Oldskool shadows are decals, not actual shadows. You can disable them if you are comfortable editing your own Oldskool files and don't plan to play online games (since that would break net compatibility for Oldskool-based coop games), though.

You'd need to edit spoldskool in Oldskool.u (under Mutator), then comment out these lines (add a // before each one), recompile, and save the package:

Code: Select all

if (!other.isa('tentacle'))     //no decal for them.
  scriptedpawn(other).Shadow = Spawn(class'olpawnShadow',other,,other.location);


That stops olPawnShadow from being applied to Scripted Pawns. Had to do this for EXU back in the day when I was working on de-Oldskooling the code as much as possible.
Image

Diego96
Skaarj Warrior Skaarj Warrior
Posts: 51
Joined: 13 Apr 2014, 19:36
Location: South 'Merica

Subject: Re: How do I disable blob shadows in UT99 Directx9?

Post Posted: 16 Aug 2017, 22:55

What program do I need to edit .u files? My UnrealED 2.0 crashes at startup.

As a last resort I will probably upload my oldskool.u to Mega.

medor
Skaarj Lord Skaarj Lord
Posts: 152
Joined: 07 Jun 2009, 22:58

Subject: Re: How do I disable blob shadows in UT99 Directx9?

Post Posted: 17 Aug 2017, 00:42

Diego96 wrote:What program do I need to edit .u files? My UnrealED 2.0 crashes at startup.

As a last resort I will probably upload my oldskool.u to Mega.


you ave probably a Steam UT or patch it 451.
back to 436 or better take my UT optimized

http://unrealtournament.99.free.fr/foru ... hp?f=4&t=7

User avatar Lightning Hunter
Skaarj Elder Skaarj Elder
Posts: 1257
Joined: 11 Nov 2007, 22:12
Location: Pervert.

Subject: Re: How do I disable blob shadows in UT99 Directx9?

Post Posted: 17 Aug 2017, 01:15

451 = worst user-made patch ever. It gives you no benefits at all, and it breaks UnrealEd. Revert to patch 436!
For High-Res Unreal skins, click here.
For the RTNP "Ultimate Edition" HD, click here.

Image

User avatar Buff Skeleton
>:E >:E
Posts: 4097
Joined: 15 Dec 2007, 00:46

Subject: Re: How do I disable blob shadows in UT99 Directx9?

Post Posted: 17 Aug 2017, 02:28

451 was for server admins, IIRC, and not intended for general player installs.
Image

Diego96
Skaarj Warrior Skaarj Warrior
Posts: 51
Joined: 13 Apr 2014, 19:36
Location: South 'Merica

Subject: Re: How do I disable blob shadows in UT99 Directx9?

Post Posted: 17 Aug 2017, 03:59

The thing is I already had it patched it to 436 (from 451) since it screwed up skyboxes in RTNP:UE. The file that's apparently causing the crash is called "FireTexture UnrealShare.Effect18.FireEffect18"

Before I do any mistakes I'll put the file here:
https://mega.nz/#!Agdj2aJR!mot-0xR0eFUU ... Ffg73kEn0Q

I'm not even sure if the file is the same for everyone (Oldskool v239) but if someone wishes to edit it for me I would be grateful.

User avatar Lightning Hunter
Skaarj Elder Skaarj Elder
Posts: 1257
Joined: 11 Nov 2007, 22:12
Location: Pervert.

Subject: Re: How do I disable blob shadows in UT99 Directx9?

Post Posted: 17 Aug 2017, 04:23

Diego96 wrote:The thing is I already had it patched it to 436 (from 451) since it screwed up skyboxes in RTNP:UE. The file that's apparently causing the crash is called "FireTexture UnrealShare.Effect18.FireEffect18"

Before I do any mistakes I'll put the file here:
https://mega.nz/#!Agdj2aJR!mot-0xR0eFUU ... Ffg73kEn0Q

I'm not even sure if the file is the same for everyone (Oldskool v239) but if someone wishes to edit it for me I would be grateful.


Better yet, I used my own modified version of oldskool for you that also fixes various other bugs. Here are a few other bugs that I remember being fixed:

-The GES Bio rifle second mode of fire is no longer messed up (no more rapid firing).
-The map pack limit of 50 has been removed (v239 has a limit of 50 map packs installed before it stops showing some of them and has issues with saved games). I think the new limit is 256.
-Weapons no longer have rotating pickup unless the map intended them to (this is how Unreal weapons are supposed to behave).

There are probably others that I have forgotten, but those are the big ones.

Download, but keep in mind this will likely break coop support (it would be broken anyway even if you removed the shadows yourself).
http://www.mediafire.com/file/ht1a3hffm ... hadows.zip
For High-Res Unreal skins, click here.
For the RTNP "Ultimate Edition" HD, click here.

Image

Diego96
Skaarj Warrior Skaarj Warrior
Posts: 51
Joined: 13 Apr 2014, 19:36
Location: South 'Merica

Subject: Re: How do I disable blob shadows in UT99 Directx9?

Post Posted: 17 Aug 2017, 08:46

You saved my life once again. Thank you Bolt Huntsman. :)


Who is online

Users browsing this forum: No registered users and 3 guests